RSVP-TE LSR
RSVP-TE applies the Resource Reservation Protocol (RSVP) for Traffic Engineering (TE), that is, to distribute MPLS labels for steering traffic and reserving bandwidth.
- RSVP-TE core protocol (RFC 2205, RFC 3209), transit role
- Hello messages (RFC 3209)
- Refresh overhead reduction (RFC 2961)
- Cryptographic authentication (RFC 2747)
- Fast Reroute: facility backup, link-protection/NHOP (RFC 4090)
- LSP Ping/Traceroute (RFC 4379)
- Fast Reroute node-protection (Starting in EOS Release 4.22.1F)
- Bandwidth management (Starting in EOS Release 4.22.1F)
- SRLG for Fast Reroute (Starting in EOS Release 4.23.1F)
- MTU signaling (Starting in EOS Release 4.23.1F)
- Soft preemption (Starting in EOS Release 4.23.1F)
- Support for OSPFv2 as the IGP (Starting in EOS Release 4.24.2F)
- Support for LDP entropy label (Starting in EOS Release 4.26.0F,RFC 6790)
RSVP-TE LSR Configuration
(config)# mpls rsvp
(config-mpls-rsvp)#
Enabling RSVP-TE
(config-mpls-rsvp)# no shutdown
(config-mpls-rsvp)# shutdown
There is no per-interface knob to enable and disable RSVP. However, you can only enable RSVP on interfaces thatMPLS is also enabled.
State Refresh Parameter
(config-mpls-rsvp)# refresh interval 30
Hello Messages
To configure the Hello message interval (seconds) and timeout multiplier (integer), refer to the following example.
(config-mpls-rsvp)# hello interval 10 multiplier 4
(config-mpls-rsvp)# default hello interval
(config-mpls-rsvp)# no hello interval
Refresh Overhead Reduction
(config-mpls-rsvp)# refresh method bundled
(config-mpls-rsvp)# refresh method explicit
Cryptographic Authentication Extension
(config-mpls-rsvp)# authentication type md5
The default is none, which disables cryptographic authentication.
(config-mpls-rsvp)# authentication index 1 password s3cr3t
(config-mpls-rsvp)# authentication index 1 active
The active password is used to authenticate outgoing messages. All configured passwords are accepted for authentication of incoming packets, which allows smooth key rollover.
(config-mpls-rsvp)# authentication index 1 password 7 07092E43
(config-mpls-rsvp)# authentication sequence-number window 5
The default value is 5. A value of 1 effectively turns off support for packet reordering.
Fast Reroute Extension
(config-mpls-rsvp)# fast-reroute mode link-protection
(config-mpls-rsvp)# fast-reroute mode none
This setting only applies to Point of Local Repair (PLR) behavior, for example, the router is the upstream node relative to a to-be-protected link over which an LSP is routed. Merge Point (MP) behavior is always enabled and not affected by this setting.
Support for Node Protection is present starting in EOS Release 4.22.1F, so the above CLI also accepts an additional mode node-protection.
(config-mpls-rsvp)# fast-reroute reversion local
(config-mpls-rsvp)# fast-reroute reversion global
Shared Risk Link Group
Starting in EOS Release 4.23.1F, there is an additional config command to configure SRLG mode.
srlg [strict]
no srlg [strict]
default srlg [strict]
This command specifies if link SRLGs of a primary LSP are to be considered as constraints while creating a fast-reroute bypass tunnel with either link or node protection. When srlg is specified with thestrict keyword, then if a path for a bypass tunnel excluding SRLGs of the next-hop interface of primary LSP can not be found, RSVP does not setup the bypass tunnel. When srlg is specified without a strict keyword, then a bypass tunnel is setup with as many links as possible that exclude the SRLGs of the next-hop interface of primary LSP and where such links are not available, links that have the least number of SRLGs which are to be excluded are used.
When this CLI is not configured, the behavior remains the same as before, which is to turn off SRLG processing. Therefore, the no and default versions of the command take you back to the default of SRLG processing being turned off.
(config)# interface Et1
(config-if-Et1)# traffic-engineering srlg 100
(config)# interface Et2
(config-if-Et2)# traffic-engineering srlg 200
CSPF Configuration Command
RSVP-TE uses CSPF to compute the FRR backup path. CSPF can be throttled to avoid frequent path changes when there are frequent network events. The following CLI command is used under the router traffic-engineering mode to specify how frequently CSPF is to run after a network event by specifying the initial wait interval, back-off interval, and maximum wait interval for CSPF.
cspf delay [initial n back-off n] max n
All three values are in milliseconds and default to 100, 200, and 1000 milliseconds, respectively.
Traffic-engineering Configuration Commands
For CSPF to compute the FRR backup path to a particular destination, enable traffic-engineering on all the IGP enabled interfaces, and enable globally the traffic engineering extensions. For IS-IS, enable under router isis mode, and for OSPFv2, enable under router ospf. This is required for the IGP to start exchanging TE-related attributes with peers and build its topology database.
Also, CSPF needs some notion of router ID to uniquely identify a router, so that it can find a path to it. CSPF also uses self router-id as a source for running SPF. So a router-id is required to be configured under router traffic-engineering mode for CSPF to function properly.
MTU Signaling
Starting in EOS Release 4.23.1F, MTU along a path can be signaled using RSVP.
Example
mtu signaling
no mtu signaling
default mtu signaling
RSVP can discover the lowest MTU used along an LSP by evaluating and updating, at each hop, the composed MTU, stored in the General Parameters fragment of an AdSpec object in RSVP Path messages.
At each RSVP hop, when MTU signaling is enabled, the value is updated by taking the minimum between the downstream interface for an LSP and the composed MTU value from the incoming Path message.
When the feature is disabled, the composed MTU is not updated.
Soft Preemption
Starting in EOS Release 4.23.1F, soft preemption is supported, which enables deferred failure of RSVP-TE LSPs on link oversubscription. A preemption timer value can be used to configure a delay on a transit router to support LSPs signaled with soft preemption enabled by the headend (RFC 5712).
preemption method [hard | soft ] timer t
no preemption method [hard | soft ] timer t
default preemption method [hard | soft ] timer t
The default preemption method is soft preemption with a timer value of 30 seconds.
In this example, the preemption method is soft preemption with a timer value of 10 seconds.
(config-mpls-rsvp)# preemption method soft timer 10
(config-mpls-rsvp)# preemption method hard
switch(config)# ip routing
!
switch(config)# mpls ip
!
switch(config)# interface Ethernet1
switch(config-if-Et1)# no switchport
switch(config-if-Et1)# ip address 10.0.0.1/24
switch(config-if-Et1)# isis enable isis
switch(config-if-Et1)# traffic-engineering
switch(config-if-Et1)# traffic-engineering bandwidth 100 percent
switch(config-if-Et1)# traffic-engineering metric 5
!
switch(config)# router traffic-engineering
switch(config-te)# router-id ipv4 0.1.1.1
!
switch(config)# router isis isis
switch(config-router-isis)# net 49.0000.0000.0000.1111.00
switch(config-router-isis)# is-type level-2
!
switch(config-router-isis)# address-family ipv4 unicast
switch(config-router-isis-af)# maximum-paths 32
!
switch(config-router-isis-af-te)# traffic-engineering
switch(config-router-isis-af-te)# no shutdown
switch(config-router-isis-af-te)# is-type level-2
!
switch(config)# mpls rsvp
switch(config-mpls-rsvp)# no shutdown
!
switch> show mpls rsvp
Administrative state: enabled
Operational state: up
Refresh interval: 30 seconds
Refresh reduction: enabled
Hello messages: enabled
Hello interval: 10 seconds
Hello multiplier: 4
Fast Re-Route: disabled
Mode: none
Hierarchical FECs: enabled
Cryptographic authentication: disabled
MTU signaling: disabled
Number of sessions: 1
Ingress/Transit/Egress: 0/1/0
Number of LSPs: 1
Operational: 1
Ingress/Transit/Egress: 0/1/0
Currently using bypass tunnels: 0
Number of bypass tunnels: 0
Number of neighbors: 2
Number of interfaces: 2
switch> show mpls rsvp neighbor
Neighbor 10.0.1.1
Upstream for
Session #1 LSP #1
Downstream for
Neighbor uptime: 00:01:24
Authentication type: disabled
Last hello received: 1 seconds ago
Last hello sent: 1 seconds ago
Bypass tunnel: not requested
Neighbor 10.0.2.2
Upstream for
Downstream for
Session #1 LSP #1
Neighbor uptime: 00:01:24
Authentication type: disabled
Last hello received: -
Last hello sent: 31 seconds ago
Bypass tunnel: not requested
switch> show mpls rsvp neighbor summary
Neighbor Role Sessions LSPs
======================================== ========== ======== ========
10.0.1.1 Upstream 1 1
10.0.2.2 Downstream 1 1
switch> show mpls rsvp session
Session #1
Destination address: 0.4.4.4
Tunnel ID: 0
Extended Tunnel ID: 0.1.1.1
Role: transit
LSP #1
State: up
Type: primary
Source address: 0.1.1.1
LSP ID: 1
LSP uptime: 00:02:38
Session name: Session1
Local label: 100000
Downstream label: 100000
Upstream neighbor: 10.0.1.1
Last refresh received: 17 seconds ago
Last refresh sent: 10 seconds ago
Downstream neighbor: 10.0.2.2
Last refresh received: 7 seconds ago
Last refresh sent: 9 seconds ago
Bypass tunnel: not requested
switch> show mpls rsvp session summary
Session Destination LSP Name Role Bypass State
======== ============= ======== =========== ======= ====== ======
1 0.4.4.4 1 Session1 transit n/req up
switch> show mpls rsvp session detail
Session #1
Destination address: 0.4.4.4
Tunnel ID: 0
Extended Tunnel ID: 0.1.1.1
Role: transit
LSP #1
State: up
[...]
MTU Signaling: enabled
Received Path MTU: 1800 bytes
Sent Path MTU: 1500 bytes
[...]
switch> show mpls rsvp counters
Received Messages:
Interface Path PathTear PathErr Resv ResvTear ResvErr Srefresh Other Errors
--------- ---- -------- ------- ---- -------- ------- -------- ----- ------
Ethernet1 5 0 0 0 0 0 8 51 1
Ethernet2 0 0 0 14 0 0 0 0 0
Sent Messages:
Interface Path PathTear PathErr Resv ResvTear ResvErr Srefresh Other Errors
--------- ---- -------- ------- ---- -------- ------- -------- ----- ------
Ethernet1 0 0 0 4 0 0 9 49 0
Ethernet2 13 0 0 0 0 0 0 4 0
Path Specifications
Path specifications can be explicit and dynamic depending on Constrained Shortest Path First (CSPF) search procedure to find a path in the network topology.
Explicit Path Specifications
switch(config-te-rsvp)# path MyPath explicit
switch(config-te-rsvp-path-expl-MyPath)#
switch(config-te-rsvp-path-expl-MyPath)# hop 10.0.12.2
(config-te-rsvp-path-expl-MyPath)# hop 10.0.34.4
switch(config-te-rsvp-path-expl-MyPath)# hop 10.0.23.3 before 10.0.34.4
switch(config-te-rsvp-path-expl-MyPath)# hop 10.0.45.5 after 10.0.34.4
switch(config-te-rsvp-path-expl-MyPath)# no hop 10.0.12.2
switch(config-te-rsvp-path-expl-MyPath)# show active
router traffic-engineering
rsvp
path MyPath explicit
hop 10.0.23.3
hop 10.0.34.4
hop 10.0.45.5
(config-te-rsvp-path-expl-MyPath)# show pending
hop 10.0.23.3
hop 10.0.44.4
hop 10.0.45.5
(config-te-rsvp-path-expl-MyPath)# show diff
hop 10.0.23.3
-hop 10.0.34.4
+hop 10.0.44.4
hop 10.0.45.5
(config-te-rsvp-path-expl-MyPath)#
switch(config-te-rsvp-path-expl-MyPath)# exit
switch(config-te-rsvp)#
switch(config-te-rsvp-path-expl-MyPath)# abort
switch(config-te-rsvp)#
Dynamic Path Specifications
In a dynamic path specification, the operator provides constraints with which a CSPF procedure finds a path in the network topology. The CSPF result is a list of strict hops which forms the ERO.
The submode to configure dynamic paths is entered by specifying the name with dynamic.
switch(config-te-rsvp)# path MyPath dynamic
switch(config-te-rsvp-path-dyn-MyPath)#
switch(config-te-rsvp-path-dyn-MyPath)# hop 10.0.56.6 exclude
switch(config-te-rsvp-path-dyn-MyPath)# hop 10.0.23.3
switch(config-te-rsvp-path-dyn-MyPath)# hop 10.0.45.5 loose
switch(config-te-rsvp-path-dyn-MyPath)# hop 10.0.12.2 before 10.0.23.3
switch(config-te-rsvp-path-dyn-MyPath)# hop 10.0.67.7 loose after 10.0.45.5
Tunnel Specifications
Tunnel specification has its own sub-mode.
switch(config-te-rsvp)# tunnel MyTunnel
switch(config-te-rsvp-tunnel-MyTunnel)#
Each tunnel has a tunnel destination IP.
switch(config-te-rsvp-tunnel-MyTunnel)# destination ip 10.2.2.2
switch(config-te-rsvp-tunnel-MyTunnel)# path MyPath
switch(config-te-rsvp-tunnel-MyTunnel)#path MyOtherPath secondary pre-signaled
switch(config-te-rsvp-tunnel-myTunnel)# bandwidth 10 mbps
switch(config-te-rsvp-tunnel-myTunnel)# bandwidth auto min 1 mbps max 5 mbps adjustment-period 60
switch(config-te-rsvp-tunnel-myTunnel)# priority setup 5 hold 3
switch(config-te-rsvp-tunnel-myTunnel)# no shutdown
switch(config-te-rsvp-tunnel-myTunnel)# exit
switch(config-te-rsvp)#
switch(config-te-rsvp-tunnel-myTunnel)# abort
switch(config-te-rsvp)#
switch(config-te-rsvp)# optimization interval 3600 seconds
switch(config-te-rsvp)#
switch(config-te-rsvp)# tunnel myTunnel
switch(config-te-rsvp-tunnel-myTunnel)# optimization interval 3600 seconds
switch(config-te-rsvp)# optimization interval 3600 seconds
switch(config-te-rsvp)# tunnel myTunnel
switch(config-te-rsvp-tunnel-myTunnel)# optimization disabled
switch(config-te-rsvp-tunnel-myTunnel)# alias endpoint 5.5.5.5
switch(config-te-rsvp-tunnel-myTunnel)# alias endpoint 2001::10
switch(config-te-rsvp-tunnel-myTunnel)# split-tunnel quantum 10 kbps
switch(config-te-rsvp-tunnel-myTunnel)# split-tunnel quantum 10 kbps sub-tunnels limit 20
IGP Shortcut in IS-IS
IGP shortcuts enable traffic to get forwarded along paths computed to take advantage of traffic-engineered paths setup using RSVP using a modified SPF algorithm. This enables operators to take advantage of TE capabilities of RSVP tunnels which traverse over links satisfying bandwidth, latency or fast reroute considerations.
IGP shortcuts are enabled on a RSVP Label Edge Router (LER) selectively on specific RSVP tunnels. When IGP shortcut is enabled, IP routes resolving over RSVP tunnels are installed in FIB. As a result all IP traffic including control plane traffic is forwarded through IGP shortcut tunnels. All protocols relying on FIB for nexthop resolution such as Static routes or BGP is also resolved over IGP shortcuts.
Configuring IGP Shortcut on RSVP Tunnel
On a RSVP LER, IGP shortcut is enabled individually on each RSVP tunnel that is intended for them. No configuration changes are needed on any of the RSVP Label Switch Routers.
switch(config)# router traffic-engineering
switch(config-te)# rsvp
switch(config-te-rsvp)# tunnel R3b
switch(config-te-rsvp-tunnel-T1)# igp shortcut
switch(config-te-rsvp-tunnel-T1)# exit
IGP shortcuts is enabled by default in IS-IS, following command disables this under the IS-ISaddress-family ipv4 mode.
switch# conf terminal
switch(config)# router isis inst1
switch(config-router-isis)# address-family ipv4
switch(config-router-isis-af)# igp shortcut disabled
Limitations
- IGP shortcut is only supported for IPv4.
- IGP shortcuts can only be computed over RSVP tunnels'
- IS-IS must be enabled on the loopback interface whose primary IP address is used as the RSVP tunnel end point.
- This is only available in the multi-agent routing protocol model.
- TI-LFA protection is not enabled for Segment Routing destinations reachable via IGP shortcuts.
Show Commands
switch# show traffic-engineering rsvp tunnel
Tunnel TestTunnel
Source: 10.1.1.1
Destination: 10.4.4.4
State: up
Bandwidth: 0.0 bps, mode explicit
LSPs: 2
Active path: primary
Primary path: Path1to4
State: up, in use
Path (dynamic):
10.0.12.2
10.0.23.3
10.0.34.4
Secondary path: Path1to4detour
State: up
Path (explicit):
10.0.16.6
10.0.67.7
10.0.37.3
10.0.34.4
switch(config)# show traffic-engineering rsvp tunnel lsp
Tunnel TestTunnel
Source: 10.1.1.1
Destination: 10.4.4.4
State: up
Bandwidth: 0.0 bps, mode explicit
LSPs: 2
Active path: primary
LSP 1:
Path specification: Path1to4, primary
CSPF Path ID: 10001
Bandwidth: 0.0 bps
State: up, in use
Path (dynamic):
10.0.12.2
10.0.23.3
10.0.34.4
LSP 2:
Path specification: Path1to4detour, secondary
Bandwidth: 0.0 bps
State: up
Path (explicit):
10.0.16.6
10.0.67.7
10.0.37.3
10.0.34.4
switch# show traffic-engineering rsvp tunnel detail
Tunnel TestTunnel
Source: 10.1.1.1
Destination: 10.4.4.4
Additional endpoints:
5.5.5.5
2001::10
State: up
Bandwidth: 0.0 bps, mode explicit
Setup priority: 7
Hold priority: 0
MTU signaling: disabled
Periodic optimization: disabled
Session #4
Tunnel index: 1
LSPs: 2
LDP tunneling: enabled
IGP shortcut: enabled
Active path: primary
Primary path: Path1to4
State: up, in use
CSPF Path ID: 10001
Path (dynamic):
10.0.12.2
10.0.23.3
10.0.34.4
Secondary path: Path1to4detour
State: up
Path (explicit):
10.0.16.6
10.0.67.7
10.0.37.3
10.0.34.4
switch# show traffic-engineering rsvp tunnel history
Tunnel TestTunnel
Mon 2020-07-13 07:04:44 CSPF query on primary path
Mon 2020-07-13 07:04:44 State change: down
Mon 2020-07-13 07:04:44 LSP #1 added
Mon 2020-07-13 07:04:44 CSPF reply for primary path, path found
Mon 2020-07-13 07:04:44 LSP #2 added
Mon 2020-07-13 07:04:46 State change: up using primary path
LSP #1
Mon 2020-07-13 07:04:44 LSP created
Mon 2020-07-13 07:04:44 State change: establishing
Mon 2020-07-13 07:04:46 State change: up
LSP #2
Mon 2020-07-13 07:04:44 LSP created
Mon 2020-07-13 07:04:44 State change: establishing
Mon 2020-07-13 07:04:47 State change: up
switch# show isis summary
IS-IS Instance: inst1 VRF: default
Instance ID: 0
System ID: 1111.1111.1001, administratively enabled
Router ID: IPv4: 1.0.5.1
Multi Topology disabled, not attached
IPv4 Preference: Level 1: 115, Level 2: 115
IPv6 Preference: Level 1: 115, Level 2: 115
IS-Type: Level 2, Number active interfaces: 3
Routes IPv4 only
LSP size maximum: Level 1: 1492, Level 2: 1492
…
Shortcut SPF for IGP: Enabled
…
switch# show isis network topology
IS-IS Instance: inst1 VRF: default
IS-IS paths to level-2 routers
System Id Metric IA Metric Next-Hop Interface SNPA
1111.1111.1003 10 0 1111.1111.1003 RSVP LER tunnel index 5 IGP Shortcut
Show Commands
RSVP Show Commands
switch> show mpls rsvp
Administrative state: enabled
Operational state: up
Refresh interval: 30 seconds
Refresh reduction: enabled
Hello messages: enabled
Hello interval: 10 seconds
Hello multiplier: 4
Fast Re-Route: disabled
Mode: none
Hierarchical FECs: enabled
Cryptographic authentication: disabled
MTU signaling: disabled
Number of sessions: 1
Ingress/Transit/Egress: 0/1/0
Number of LSPs: 1
Operational: 1
Ingress/Transit/Egress: 0/1/0
Currently using bypass tunnels: 0
Number of bypass tunnels: 0
Number of neighbors: 2
Number of interfaces: 2
switch> show mpls rsvp neighbor
Neighbor 10.0.1.1
Upstream for
Session #1 LSP #1
Downstream for
Neighbor uptime: 00:01:24
Authentication type: disabled
Last hello received: 1 seconds ago
Last hello sent: 1 seconds ago
Bypass tunnel: not requested
Neighbor 10.0.2.2
Upstream for
Downstream for
Session #1 LSP #1
Neighbor uptime: 00:01:24
Authentication type: disabled
Last hello received: -
Last hello sent: 31 seconds ago
Bypass tunnel: not requested
switch> show mpls rsvp neighbor summary
Neighbor Role Sessions LSPs
==================== ========== ======== ========
10.0.1.1 Upstream 1 1
10.0.2.2 Downstream 1 1
switch> show mpls rsvp session
Session #1
Destination address: 0.4.4.4
Tunnel ID: 0
Extended Tunnel ID: 0.1.1.1
Role: transit
LSP #1
State: up
Type: primary
Source address: 0.1.1.1
LSP ID: 1
LSP uptime: 00:02:38
Session name: Session1
Local label: 100000
Downstream label: 100000
Upstream neighbor: 10.0.1.1
Last refresh received: 17 seconds ago
Last refresh sent: 10 seconds ago
Downstream neighbor: 10.0.2.2
Last refresh received: 7 seconds ago
Last refresh sent: 9 seconds ago
Bypass tunnel: not requested
switch> show mpls rsvp session summary
Session Destination LSP Name Role Bypass State
======== ================== ======== ============ ======= ====== =========
1 0.4.4.4 1 Session1 transit n/req up
switch> show mpls rsvp session detail
Session #1
Destination address: 0.4.4.4
Tunnel ID: 0
Extended Tunnel ID: 0.1.1.1
Role: transit
LSP #1
State: up
[...]
MTU Signaling: enabled
Received Path MTU: 1800 bytes
Sent Path MTU: 1500 bytes
[...]
switch> show mpls rsvp counters
Received Messages:
Interface Path PathTear PathErr Resv ResvTear ResvErr Srefresh Other Errors
--------- ---- -------- ------- ---- -------- ------- -------- ----- ------
Ethernet1 5 0 0 0 0 0 8 51 1
Ethernet2 0 0 0 14 0 0 0 0 0
Sent Messages:
Interface Path PathTear PathErr Resv ResvTear ResvErr Srefresh Other Errors
--------- ---- -------- ------- ---- -------- ------- -------- ----- ------
Ethernet1 0 0 0 4 0 0 9 49 0
Ethernet2 13 0 0 0 0 0 0 4 0
CSPF Show Commands
RSVP-TE uses CSPF to compute the FRR backup path. Starting from EOS Release 4.23.1F, if srlg is configured in RSVPconfig to exclude SRLG, then details about the SRLG related constraint attributes are also shown as in the following show commands.
switch> show traffic-engineering cspf path 20.0.0.1 20.0.0.1
Destination Constraint Path
20.0.0.1 exclude Ethernet1 0.1.1.1
exclude SRLG of Ethernet1 0.1.1.2
0.2.2.2
3.3.3.2
exclude Ethernet2 0.1.1.1
0.1.1.2
0.2.2.2
3.3.3.2
switch> show traffic-engineering cspf path 20.0.0.1 detail
Destination: 20.0.0.1
Path Constraint: exclude Ethernet1
exclude SRLG of Ethernet1: orange-link (500),
green-link (400), 100, red-link (200), 600
Request Sequence number: 1
Response Sequence number: 1
Number of times path updated: 2
Last updated: 00:01:58
Reoptimize: Always
Path:
0.1.1.1
0.1.1.2
0.2.2.2
3.3.3.2
Path Constraint: exclude Ethernet2
Request Sequence number: 2
Response Sequence number: 2
Number of times path updated: 3
Last updated: 00:00:38
Reoptimize: Always
Path:
0.1.1.1
0.1.1.2
0.2.2.2
3.3.3.2
Displaying the Traffic-engineering Database
You can display the topology used for CSPF computations by using the show traffic-engineering database command. Starting from EOS Release 4.23.1F, the SRLG group details of a neighbor are shown if it is advertised.
switch# show traffic-engineering database
TE Router-ID: 1.0.0.2
Source: IS-IS Level-1 IPv4 Topology Database
IS-IS System-ID: 1111.1111.1001
Number of Links: 2
Network type: P2P
Neighbor: 1111.1111.1002
Administrative group (Color): 0x123a
TE Metric: 30
IPv4 Interface Addresses:
20.20.20.1
192.168.20.1
IPv4 Neighbor Addresses:
20.20.20.2
192.168.20.2
Maximum link BW: 25.00 Gbps
Maximum reservable link BW: 10.00 Mbps
Unreserved BW:
TE class 0: 9.00 Mbps TE class 1: 9.00 Mbps
TE class 2: 8.5.00 Mbps TE class 3: 8.00 Mbps
TE class 4: 7.00 Mbps TE class 5: 7.50 Mbps
TE class 6: 6.00 Mbps TE class 7: 6.00 Mbps
Network Type: LAN
Neighbor: 1111.1111.1003.02
TE Metric: 30
Administrative Group: 0x12
IPv4 Local Addresses:
30.30.30.1
Maximum Link BW: 10.00 Gbps
Maximum Reservable Link BW: 10.50 Gbps
Unreserved BW:
TE-Class 0: 8.50 Gbps TE-Class 1: 8.70 Gbps
TE-Class 2: 7.50 Gbps TE-Class 3: 7.25 Gbps
TE-Class 4: 6.50 Gbps TE-Class 5: 7.30 Gbps
TE-Class 6: 3.50 Gbps TE-Class 7: 7.20 Gbps
Source: IS-IS Level-2 IPv4 Topology Database
IS-IS System-ID: 1111.1111.1003
Number of Links: 1
Network Type: LAN
Neighbor: 1111.1111.1003.16
IPv4 Local Addresses:
40.40.40.1
Maximum link BW: 10.00 Gbps
Maximum reservable link BW: 5.00 Gbps
Unreserved BW:
TE class 0: 4.00 Gbps TE class 1: 4.00 Gbps
TE class 2: 4.00 Gbps TE class 3: 4.00 Gbps
TE class 4: 3.00 Gbps TE class 5: 3.00 Gbps
TE class 6: 3.00 Gbps TE class 7: 3.00 Gbps
Source: OSPFv2 Instance ID 33 Area-ID 0.0.0.0 Topology Database
OSPFv2 Router-ID: 1.2.3.4
Number of Links: 2
Network type: P2P
Neighbor: 3.4.5.6
Administrative group (Color): 0x123a
TE metric: 30
IPv4 Interface Addresses:
20.20.20.1
192.168.20.1
IPv4 Neighbor Addresses:
20.20.20.2
192.168.20.1
Maximum link BW: 25.00 Gbps
Maximum reservable link BW: 10.00 Mbps
Unreserved BW:
TE class 0: 9.00 Mbps TE class 1: 9.00 Mbps
TE class 2: 8.50 Mbps TE class 3: 8.00 Mbps
TE class 4: 7.00 Mbps TE class 5: 7.50 Mbps
TE class 6: 6.00 Mbps TE class 7: 6.00 Mbps
Network type: LAN
Neighbor: 2.3.4.5
Administrative group (Color): 0x12
TE metric: 30
IPv4 Interface Addresses:
30.30.30.1
IPv4 Neighbor Addresses:
0.0.0.0
Maximum link BW: 10.00 Gbps
Maximum reservable link BW: 10.5 Gbps
Unreserved BW:
TE class 0: 8.50 Gbps TE class 1: 8.70 Gbps
TE class 2: 7.50 Gbps TE class 3: 7.25 Gbps
TE class 4: 6.50 Gbps TE class 5: 7.30 Gbps
TE class 6: 3.50 Gbps TE class 7: 7.20 Gbps
TE Router-ID: 1.0.0.3
Source: IS-IS Level-1 IPv4 Topology Database
IS-IS System-ID: 1111.1111.1004
Number of Links: 2
Network type: P2P
Neighbor: 1111.1111.1002
IPv4 Interface Addresses:
1.0.5.1
IPv4 Neighbor Addresses:
1.0.5.2
Maximum link BW: 50.00 Gbps
Maximum reservable link BW: 10.00 Gbps
Unreserved BW:
TE class 0: 8.00 Gbps TE class 1: 8.00 Gbps
TE class 2: 8.00 Gbps TE class 3: 8.00 Gbps
TE class 4: 7.00 Gbps TE class 5: 7.00 Gbps
TE class 6: 7.00 Gbps TE class 7: 7.00 Gbps
Shared Risk Link Group:
Group: 100
Group: green-link (150)
Limitations
- Supports only IPv4.
- Supports only the default VRF.
- Supports only strict EROs with host hops (/32).
- Supports only transit role functionality.
- Traffic Engineering links with secondary IP addresses are not supported.
- The maximum number of supported RSVP sessions and LSPs is 5000.
- For FRR, the maximum number of supported LSPs per interface is 2000.
- Changing the RSVP FRR mode while a bypass tunnel is already in use can bring down both primary and bypass tunnels which cause traffic loss.
- Changing the RSVP SRLG mode while a bypass tunnel is already in use could bring down both primary and bypass tunnels which cause traffic loss.
- The maximum number of IS-IS/OSPFv2 routers supported by CSPF on a single broadcast network is 30.
- The maximum number of IS-IS/OSPFv2 adjacencies supported by CSPF for a single router is 500.
- CSPF only takes into account a maximum of 16 SRLGs per TE link, when excluding SRLGs while computing a path.